Help+Manual-Forum von HelpDesign • Jörg Ertelt Foren-Übersicht Help+Manual-Forum von HelpDesign • Jörg Ertelt
Erstes deutschsprachiges Help& Manual-Forum
 
 ProfilProfil   LoginLogin 
 FAQFAQ   SuchenSuchen  RegistrierenRegistrieren 
 HelpDesign { Seminare und Support | Testlizenz anfordern | Neue Lizenzen kaufen / Lizenzen upgraden }

SVG-Dateien nicht korrekt angezeigt

 
Neues Thema eröffnen   Neue Antwort erstellen    Help+Manual-Forum von HelpDesign • Jörg Ertelt Foren-Übersicht -> Import / Export
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
ZRHSAT



Anmeldungsdatum: 25.02.2015
Beiträge: 6

BeitragVerfasst am: Mo Apr 04, 2016 18:18    Titel: SVG-Dateien nicht korrekt angezeigt Antworten mit Zitat

Hallo

Ich arbeite mit der aktuellsten Version von H&M unter Win 7 Enterprise und möchte SVG-Grafiken einbinden. Leider erscheint immer nur die Grafik mit einem Kreuz (quasi "broken" Format) und wenn ich das Projekt nach HTML publiziere, wird eine 32x32 Pixel grosse Darstellung der Grafik angezeigt.

Muss ich evtl. einen speziellen Treiber/Renderer/was auch immer installieren, damit H&M korrekt mit SVG umgehen kann? Mein Arbeitskollege mit "in etwa" derselben Arbeitsumgebung hat dieses Problem nicht.

Merci für jede Antwort
Ernst
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden
Alexander Halser



Anmeldungsdatum: 23.12.2005
Beiträge: 226
Wohnort: Salzburg

BeitragVerfasst am: Di Apr 05, 2016 21:05    Titel: Antworten mit Zitat

Hallo Ernst,

einen Treiber benötigen Sie nicht. Das ist das Error-Symbol, wenn eine Bilddatei (egal welche) nicht angezeigt werden kann. Das kann bedeuten, daß H&M das Bild nicht findet, oder aber daß es die SVG-Datei nicht dekodieren kann, weil sie einen Fehler enthält (oder H&M mit dem XML darin nicht klarkommt).

Halten Sie doch mal mit dem Mauszeiger auf das Error-Bild und warten Sie einen Moment, bis die Info-Anzeige unter der Maus erscheint. Da steht drinnen "Bild: <pfad>\Bildname.svg"

Wenn nur der Name der Bilddatei erscheint, ohne den Pfad davor, dann wurde die Datei nicht gefunden. In dem Fall prüfen Sie bitte den Suchpfad in den Projekteinstellungen.

Wenn hingegen die Bilddatei mit Pfad angezeigt wird, dann ist der Error beim Dekodieren des SVG-Bildes entstanden. Das passiert sicherlich nicht bei allen SVGs. Bitte senden Sie mir in diesem Fall ein paar solcher SVGs zum Testen. Email: alexander.halser (ät) ec-software.com

Zitat:
Mein Arbeitskollege mit "in etwa" derselben Arbeitsumgebung hat dieses Problem nicht.


Das deutet auf die erste Variante hin. Wenn diese Bilder vom Kollegen eingefügt wurden und Sie beim Öffnen der Topics nur ein Error-Bild sehen, dann liegt es höchstwahrscheinlich am Suchpfad. Help+Manual speichert Bilder nur mit dem Dateinamen, ohne Pfad. Zusätzlich verwaltet es einen Suchpfad (unter Konfiguration > Allgemeine Einstellungen > Suchpfad), über den es die Bilder, Videos, Snippets und was immer sonst noch eingebettet wird, findet. Hier könnte von Ihrem Kollegen beim Einfügen der Bilder ein Pfad hinterlegt worden sein, der auf Ihrem Rechner so nicht gilt. Die saubere Lösung wäre, das Projekt und die Bilder auf einen Server-Pfad zu verlegen, der für alle Anwender der gleiche ist. Sie können aber auch den Pfad manuell hinzufügen, und zwar so wie der Quell-Ordner von Ihrem PC aus heißt. Findet H&M die Bilder im ersten Suchpfad nicht, dann eben im zweiten.
_________________
Alexander Halser
Support, Help & Manual
www.helpandmanual.com
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen
ZRHSAT



Anmeldungsdatum: 25.02.2015
Beiträge: 6

BeitragVerfasst am: Mi Apr 06, 2016 08:43    Titel: Antworten mit Zitat

Hallo Alex

Merci vielmals für die Antwort. Habe alles ausprobiert und gegengeprüft mit meinem Arbeitskollegen. Das Problem blieb bestehen. Darum einfach mal H&M komplett deinstalliert und die neuste Version (was vorher schon der Fall war, aber per "Update") installiert. Resultat: jetzt funktionierts.

Viele Grüsse
Ernst
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden
Beiträge der letzten Zeit anzeigen:   
Neues Thema eröffnen   Neue Antwort erstellen    Help+Manual-Forum von HelpDesign • Jörg Ertelt Foren-Übersicht -> Import / Export Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehe zu:  
Sie können keine Beiträge in dieses Forum schreiben.
Sie können auf Beiträge in diesem Forum nicht antworten.
Sie können Ihre Beiträge in diesem Forum nicht bearbeiten.
Sie können Ihre Beiträge in diesem Forum nicht löschen.
Sie können an Umfragen in diesem Forum nicht teilnehmen.


Powered by phpBB © 2001, 2005 phpBB Group
Deutsche Übersetzung von phpBB.de