Help+Manual-Forum von HelpDesign • Jörg Ertelt Foren-Übersicht Help+Manual-Forum von HelpDesign • Jörg Ertelt
Erstes deutschsprachiges Help& Manual-Forum
 
 ProfilProfil   LoginLogin 
 FAQFAQ   SuchenSuchen  RegistrierenRegistrieren 
 HelpDesign { Seminare und Support | Testlizenz anfordern | Neue Lizenzen kaufen / Lizenzen upgraden }

Links mit Ankern funktionieren nicht mehr in Version 7

 
Neues Thema eröffnen   Neue Antwort erstellen    Help+Manual-Forum von HelpDesign • Jörg Ertelt Foren-Übersicht -> Microsoft HTML Help (.chm)
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
nkraiczi



Anmeldungsdatum: 04.11.2015
Beiträge: 10
Wohnort: DE - Rheinland-Pfalz

BeitragVerfasst am: Fr Nov 06, 2015 11:33    Titel: Links mit Ankern funktionieren nicht mehr in Version 7 Antworten mit Zitat

Hallo,

die Links, welche Anker enthalten und in Help & Manual 6 angelegt wurden, funktionieren nicht mehr mit Help & Manual 7 (7.0.6 Build 3732). Wie macht man diese wieder nutzbar, ohne manuelle Einzelanpassungen?

Beispiel-XML:
Topic mit Ankerlink (Auszug):

Code:
<body>
    <header>
      <para styleclass="Heading1"><text styleclass="Heading1" translate="true">PBA</text></para>
    </header>
    <para styleclass="Kapitelüberschrift"><text styleclass="Kapitelüberschrift" translate="true">Konzept</text></para>
    <para styleclass="Normal"><text styleclass="Comment" translate="true">Um diesen Dialog zu öffnen, klicken Sie auf den Reiter ...</text></para>
    <para styleclass="Normal"></para>
    <para styleclass="Normal"><text styleclass="Normal" translate="true">Hier können Sie die</text><text styleclass="Hervorhebung Term" translate="true"> </text><image src="glossar_link.jpeg" scale="100.00%" styleclass="Hervorhebung Term"></image><text styleclass="Hervorhebung Term" translate="true"> </text><link displaytype="text" defaultstyle="true" type="topiclink" href="Glossar" anchor="Personalvorgabe" styleclass="Normal" translate="true">Personalvorgaben</link><text styleclass="Normal" translate="true"> laut (...) abzuleiten.</text></para>


Beispiel-XML:
Topic mit Sprungziel (Auszug):

Code:
<body>
    <header>
      <para styleclass="Heading1"><text styleclass="Heading1" translate="true">Glossar</text></para>
    </header>
   <para styleclass="Abschnitt"><anchor id="Index_P" styleclass="Abschnitt"></anchor><text styleclass="Abschnitt" translate="true">P</text></para>
    <para styleclass="Glossar"><anchor id="Personalvorgabe" styleclass="Glossar"></anchor><text styleclass="Glossar" translate="true">Personalvorgabe</text></para>
    <para styleclass="Normal"><text styleclass="Normal" translate="true">Die Personalvorgabe ist ... </text></para>


Danke und Gruß
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden
Jörg Ertelt
Moderator


Anmeldungsdatum: 22.12.2005
Beiträge: 2403
Wohnort: 73240 Wendlingen

BeitragVerfasst am: Sa Nov 07, 2015 10:25    Titel: Antworten mit Zitat

Guten Tag nkraiczi,

Ich kann das Verhalten mit einem Testprojekt nicht reproduzieren: HuM 6-Projekt angelegt mit Topics A und B. Topic A enthält einen Text-Link auf einen Anker in Topic B. CHM erzeugt. Ergebnis: Funktioniert.

Selbes Projekt mit HuM 7 geöffnet, Inhalt hinzugefügt, gespeichert, CHM erzeugt. Ergebnis: Funktioniert.

Auch ist mir nicht bekannt, dass es bei solchen Links beim Versionswechsel zu Problemen gekommen sei. Ausnahme: Links auf Anker, im selben(!) (Details: http://www.helpandmanual.com/help/hm_whatsnew_misc.htm > Links to anchors in the current topic) Topic, die mit HuM 6 erzeugt wurden, funktionieren mit HuM 7 nicht mehr.
Aber das ist ja nicht der beschrieben Fall.

Ggf. handelt es sich um einen toten Link, den Help & Manual dank einer Einstellung entfernt hat: Ansicht > Benutzereinstellungen > Compiler > Link entfernen.
Bitte prüfen.
_________________
Viele Grüße

Jörg Ertelt

HELP+MANUAL
:: Testlizenz anfordern
:: Neue Lizenzen kaufen / Lizenzen upgraden
:: Offene und Firmenseminare

SUPPORT
:: Help+Manual-Forum
:: Help+Manual-Knowledgebase

HelpDesign • Jörg Ertelt
Ulrichstraße 1
D-73240 Wendlingen am Neckar
www.helpdesign.eu

Nach oben
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen
nkraiczi



Anmeldungsdatum: 04.11.2015
Beiträge: 10
Wohnort: DE - Rheinland-Pfalz

BeitragVerfasst am: Mi Nov 18, 2015 13:36    Titel: Antworten mit Zitat

Hallo,

mit einer aktualisierten Skin-Datei funktioniert dies nun.

Danke und Grüße
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden
Jörg Ertelt
Moderator


Anmeldungsdatum: 22.12.2005
Beiträge: 2403
Wohnort: 73240 Wendlingen

BeitragVerfasst am: Mi Nov 18, 2015 15:37    Titel: Antworten mit Zitat

Bestens, danke für die Rückmeldung.
_________________
Viele Grüße

Jörg Ertelt

HELP+MANUAL
:: Testlizenz anfordern
:: Neue Lizenzen kaufen / Lizenzen upgraden
:: Offene und Firmenseminare

SUPPORT
:: Help+Manual-Forum
:: Help+Manual-Knowledgebase

HelpDesign • Jörg Ertelt
Ulrichstraße 1
D-73240 Wendlingen am Neckar
www.helpdesign.eu

Nach oben
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen
Beiträge der letzten Zeit anzeigen:   
Neues Thema eröffnen   Neue Antwort erstellen    Help+Manual-Forum von HelpDesign • Jörg Ertelt Foren-Übersicht -> Microsoft HTML Help (.chm) Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehe zu:  
Sie können keine Beiträge in dieses Forum schreiben.
Sie können auf Beiträge in diesem Forum nicht antworten.
Sie können Ihre Beiträge in diesem Forum nicht bearbeiten.
Sie können Ihre Beiträge in diesem Forum nicht löschen.
Sie können an Umfragen in diesem Forum nicht teilnehmen.


Powered by phpBB © 2001, 2005 phpBB Group
Deutsche Übersetzung von phpBB.de