Help+Manual-Forum von HelpDesign • Jörg Ertelt Foren-Übersicht Help+Manual-Forum von HelpDesign • Jörg Ertelt
Erstes deutschsprachiges Help& Manual-Forum
 
 ProfilProfil   LoginLogin 
 FAQFAQ   SuchenSuchen  RegistrierenRegistrieren 
 HelpDesign { Seminare und Support | Testlizenz anfordern | Neue Lizenzen kaufen / Lizenzen upgraden }

Benutzung des Style Repositorys

 
Neues Thema eröffnen   Neue Antwort erstellen    Help+Manual-Forum von HelpDesign • Jörg Ertelt Foren-Übersicht -> Allgemeine Themen
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
hausklaus



Anmeldungsdatum: 01.12.2017
Beiträge: 3

BeitragVerfasst am: Di Dez 12, 2017 11:43    Titel: Benutzung des Style Repositorys Antworten mit Zitat

Hallo zusammen,

Ich habe ein Projekt, bei dem ich zwei Versionen eines Programms habe. Bei der Hilfe brauche ich also zwei Versionen mit unterschiedlichen Screenshots und Variablen (z.B. dem Programmnamen), die dann unterschiedlich belegt werden. Der Rest ist identisch (später unterscheiden sie sich vielleicht noch etwas mehr, aber das sollte kein Problem sein).

Zur Umsetzung habe ich mich für ein Style Repository entschieden. Die Inhalte (Topics) liegen zu 100% in der Bibliothek und werden in den beiden Projekten als Snippets in leere Topics eingefügt. Jedes Projekt hat seinen eigenen Bildersuchpfad und da die Bilder gleiche Dateinamen haben, klappt das auch so.

Das Problem, das ich habe, möchte ich am folgenden Beispiel klarmachen:

Ich habe in der Bibliothek topic1.xml und topic2.xml, wobei in topic1.xml ein Link auf topic2.xml vorkommt. Wenn ich jetzt in einem der verknüpften Projekte ein topic2.xml erstelle und darin das topic2.xml aus der Bibliothek als snippet einfüge, findet er das topic nicht (das snippet ist leer bis auf eine Fehlermeldung). Wenn ich das topic in dem realisierenden Project anders nenne, z.B. topic3 und dann topic2.xml als Snippet einfüge, funktioniert es, allerdings zeigt der Link aus topic1 (angenommen, ich füge das auch in ein Topic als Snippet ein) immernoch auf "topic2" und funktioniert deswegen nicht.

Ich habe das jetzt umgangen in dem ich in der Bibliothek für jedes Topic immer noch ein Dummy-Topic angelegt habe, worauf dann die Links für das Topic verweisen und im Projekt heißt das Topic wo das Snippet reinkommt dann immer so wie das Dummy Topic, aber ich habe das Gefühl, dass dieser Weg viel zu umständlich ist und dass das eigentlich auch anders gehen müsste.

Vielen Dank für die Antworten.
Mit freundlichen Grüßen.

hausklaus
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden
Jörg Ertelt
Moderator


Anmeldungsdatum: 22.12.2005
Beiträge: 2491
Wohnort: 73240 Wendlingen

BeitragVerfasst am: Di Dez 12, 2017 19:19    Titel: Antworten mit Zitat

Guten Tag hausklaus,

Das Problem besteht darin, dass Sie ein Topic in ein andere Topic mit identischem Dateinamen einsetzen. Die Dateinamen müssen sich zwingend unterscheiden.

Am einfachsten ist es, wenn Sie im Repository vor jeden Dateinamen eines Topics ein Präfix setzen, z. B. lib_
Das Beste: Sie können das Präfix im Repository hinterlegen. Dann wird dieses Präfix beim Anlegen eines Topics automatisch als Präfix in den Topic-Dateinamen eingefügt.
Präfix hinterlegen: Konfiguration > Allgemeine Einstellungen > Verschiedene Optionen > Topic ID Prefix > Beim Anlegen von neuen Topics ... (Präfix einsetzen)
_________________
Viele Grüße

Jörg Ertelt

HELP+MANUAL
:: Testlizenz anfordern
:: Neue Lizenzen kaufen / Lizenzen upgraden
:: Offene und Firmenseminare

SUPPORT
:: Help+Manual-Forum
:: Help+Manual-Knowledgebase

HelpDesign • Jörg Ertelt
Ulrichstraße 1
D-73240 Wendlingen am Neckar
www.helpdesign.eu

Nach oben
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen
hausklaus



Anmeldungsdatum: 01.12.2017
Beiträge: 3

BeitragVerfasst am: Fr Dez 15, 2017 11:05    Titel: Antworten mit Zitat

Hallo Herr Ertelt,

vielen Dank für Ihre Antwort. Wenn ich die Dateien in der Bibliothek unterschiedlich nenne, habe ich das Problem, dass Topic-Links im Projekt nicht mehr funktionieren:

Lib:
    lib_topic1.xml enthält link auf lib_topic2.xml
    lib_topic2.xml


Projekt:

    topic1 enthält lib_topic1.xml als snippet
    topic2 enthält lib_topic2.xml als snippet



Bei Export des Projekts als WebHelp kommt folgender Fehler:

Code:
Topic Topic1 referenziert ein undefiniertes Topic: "lib_Topic2"


Die .html-Datei enthält entsprechend:

a href= "lib_topic2.html" class="topiclink"


Schöne Grüße und schönes Wochenende

hausklaus
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden
Jörg Ertelt
Moderator


Anmeldungsdatum: 22.12.2005
Beiträge: 2491
Wohnort: 73240 Wendlingen

BeitragVerfasst am: Sa Dez 16, 2017 00:07    Titel: Antworten mit Zitat

==
habe ich das Problem, dass Topic-Links im Projekt nicht mehr funktionieren:
==

Das ist korrekt-damit es funktioniert, setzen Sie den Link inlib_topic1.xml auf topic2.xml und umgekehrt. Dann ist zwar lib_topic1.xml Inhalt von topic1.xml, der allerdings im Snippet lib_topic1.xml auf topic2.xml referenziert.
Die Links referenzieren immer auf Topics, und nicht auf Snippets in einem Topic.
_________________
Viele Grüße

Jörg Ertelt

HELP+MANUAL
:: Testlizenz anfordern
:: Neue Lizenzen kaufen / Lizenzen upgraden
:: Offene und Firmenseminare

SUPPORT
:: Help+Manual-Forum
:: Help+Manual-Knowledgebase

HelpDesign • Jörg Ertelt
Ulrichstraße 1
D-73240 Wendlingen am Neckar
www.helpdesign.eu

Nach oben
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen
hausklaus



Anmeldungsdatum: 01.12.2017
Beiträge: 3

BeitragVerfasst am: Fr Dez 29, 2017 12:36    Titel: Antworten mit Zitat

Vielen Dank für die Antwort.

Mit Ihrer Lösung funktioniert es. Das Problem ist (wenn ich mich nicht irre), dass alle Links in der Bibliothek als tot angesehen werden, was logisch ist, da die Bibliothek ja nicht weiß, welche Projekte ihre Topics verwenden.

Dadurch geht die ganze Funkionalität der Prüfung von Links und das automatische Anpassen von Links beim Umbennen von Topics verloren.

Da mir diese Funktionen wichtiger sind, würde ich eher bei dem work-around mit den Doppeltopics bleiben um die Integrität der Linkstruktur zu bewahren.

Vielen Dank für Ihre Hilfe und einen guten Rutsch ins neue Jahr.
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden
Beiträge der letzten Zeit anzeigen:   
Neues Thema eröffnen   Neue Antwort erstellen    Help+Manual-Forum von HelpDesign • Jörg Ertelt Foren-Übersicht -> Allgemeine Themen Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehe zu:  
Sie können keine Beiträge in dieses Forum schreiben.
Sie können auf Beiträge in diesem Forum nicht antworten.
Sie können Ihre Beiträge in diesem Forum nicht bearbeiten.
Sie können Ihre Beiträge in diesem Forum nicht löschen.
Sie können an Umfragen in diesem Forum nicht teilnehmen.


Powered by phpBB © 2001, 2005 phpBB Group
Deutsche Übersetzung von phpBB.de