Help+Manual-Forum von HelpDesign • Jörg Ertelt Foren-Übersicht Help+Manual-Forum von HelpDesign • Jörg Ertelt
Erstes deutschsprachiges Help& Manual-Forum
 
 ProfilProfil   LoginLogin 
 FAQFAQ   SuchenSuchen  RegistrierenRegistrieren 
 HelpDesign { Seminare und Support | Testlizenz anfordern | Neue Lizenzen kaufen / Lizenzen upgraden }

Externe Dateien aus .chm-Dateien öffnen

 
Neues Thema eröffnen   Neue Antwort erstellen    Help+Manual-Forum von HelpDesign • Jörg Ertelt Foren-Übersicht -> Microsoft HTML Help (.chm)
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Jörg Ertelt
Moderator


Anmeldungsdatum: 22.12.2005
Beiträge: 2403
Wohnort: 73240 Wendlingen

BeitragVerfasst am: Di Okt 30, 2007 19:42    Titel: Externe Dateien aus .chm-Dateien öffnen Antworten mit Zitat

Die nachfolgende Beschreibung bezieht sich auf Help & Manual Version 4! (Es funktioniert auch mit HuM5, allerdings finden sich einige Einstellungen an anderer Stelle)



Liebe Forums-Leser,



es geht mal wieder um das leidige Thema "externe Dateien, vorzugsweise PDF, aus einer .chm-Datei öffnen". Analog gilt dieser Anspruch für jeden anderen Dateityp.



Zur Umsetzung gibt es unterschiedliche Lösungen: Shortcuts (ActiveX Controls), JavaScripte und anderes. Mal funktioniert die eine, mal die andere Lösung. Oder eben auch nicht. Insbesondere seit SP2 unter Windows XP eingeführt wurde, ging die Malaise richtig los.



Ich habe nun eine Lösung gefunden, die auf JScript (Microsoft Derrivat von JavaScript) basiert und immun zu sein scheint gegenüber diversen Microsoft-Patches. Weiterer Vorteil: Es wird kein Downloadfenster angezeigt, jedenfalls nicht bei PFD und die Dateien werden gemäß meinen Tests im .chm-Viewer anstelle des jeweiligen Topics geöffnet. Konnte das verifizieren für PDF- und Word-Dateien.



Die Zutaten zur Umsetzung der Lösung:

* eine JavaScript-Datei mit JScript-Funktionen

* eine Masterpage

* einen JavaScript-Aufruf

* externen Dateien beliebigen Typs



Und so funktionierts:



Vorarbeit

1. Laden Sie sich die erforderliche JavaScript-Datei herunter: Helpesign.zip

2. Entpacken Sie Helpesign.zip in ein beliebiges Verzeichnis

3. Öffnen Sie ein Help & Manual-Projekt

4. Fügen Sie die HelpDesign.js zum Projekt hinzu: Menü Project > Project Properties > Common Properties > Baggage Files > Add File > Dateityp > All files > HelpDesign.js wählen > Öffnen > OK



Umsetzung

1. Einen Topic öffnen oder einen neuen Topic anlegen

2. In diesem Topic den Pfad zur HelpDesign.js eintragen: Menü Insert > HTML Plain Code > folgenen Code eingeben:
Code:
<script language="JavaScript" src="HelpDesign.js"></script>
> OK

3. Im Topic den Cursor an der Stelle platzieren, an der der Link auf die externe Datei hinterlegt werden soll

4. Über Menü Insert > HTML Plain Code > folgenen Code eingeben:
Code:
<a onclick="parser('Manual.pdf')" style="text-decoration: underline; color: green; cursor: hand">Link auf n externes PDF</a>
> OK

5. Das blaue <a-Element doppelklicken

6. Den Dateinamen im Ausdruck ('Manual.pdf') durch den Dateinamen der tatsächlichen Datei ersetzen

7. Das saloppe Link auf n externes PDF durch einen seriösen Text ersetzen. Dabei handelt es sich um den Linktext > OK.

8. Alles speichern

9. .chm generieren

10. Die externe Datei in das Verzeichnis kopieren, in der sich die generierte .chm-Datei befindet.

WICHTIG: Diese externen Dateien müssen im selben Verzeichnis wie die .chm liegen, sonst funktionierts nicht.

11. .chm öffnen, Link klicken und staunen ...



Zum Nachlesen die Original-Quelle: http://msdn2.microsoft.com/en-us/library/ms644690.aspx
_________________
Viele Grüße

Jörg Ertelt

HELP+MANUAL
:: Testlizenz anfordern
:: Neue Lizenzen kaufen / Lizenzen upgraden
:: Offene und Firmenseminare

SUPPORT
:: Help+Manual-Forum
:: Help+Manual-Knowledgebase

HelpDesign • Jörg Ertelt
Ulrichstraße 1
D-73240 Wendlingen am Neckar
www.helpdesign.eu



Zuletzt bearbeitet von Jörg Ertelt am Di Apr 18, 2017 19:28, insgesamt 4-mal bearbeitet
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen
pit2008



Anmeldungsdatum: 15.11.2008
Beiträge: 17

BeitragVerfasst am: Do Nov 20, 2008 17:47    Titel: schäm mich fast diese einfache Lösung zu schreiben Antworten mit Zitat

Das mit dem Script hat bei mir nicht geklappt.

Habs mit HTML probiert ...

-> Edit HTML Code ....

a href="file://Server/kurzliste.pdf">Kurze Liste</a>"

- > ok.

File erstellen, geht perfekt.



Vor dem A noch eine < kann ich hier im Forum nicht einfügen sonst verschwindet die Zeile
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden
Jörg Ertelt
Moderator


Anmeldungsdatum: 22.12.2005
Beiträge: 2403
Wohnort: 73240 Wendlingen

BeitragVerfasst am: Sa Nov 22, 2008 22:10    Titel: Antworten mit Zitat

==

a href="file://Server/kurzliste.pdf">Kurze Liste</a>"

- > ok.

File erstellen, geht perfekt

==



Mhm. Das "file://Server/kurzliste.pdf" ist ein absoluter Link. Auf einem anderen Rechner wird das nicht funktionieren, weil der Pfad nicht vorhanden ist. Das Skript hingegen setzt den absoluten Pfad zu Laufzeit zusammen. Deshalb ist es dann egal, wo sich die Zieldatei befindet.



BTW: Das Skript funktioniert sehr wohl. Ich habe ein kleine Help & Manual 5-Projekt erstellt und hochgeladen. Download hier.



Im _Output-Ordner befindet sich eine .chm- und .pdf-Datei. .chm starten und die Links klicken.



==

Vor dem A noch eine < kann ich hier im Forum nicht einfügen sonst verschwindet die Zeile

==



Im Forum kann auch HTML-Code veröffentlicht werden. Einfach unterhalb des Editor-Fenster die Option HTML in diesem Beitrag deaktivieren ankreuzen.
_________________
Viele Grüße

Jörg Ertelt

HELP+MANUAL
:: Testlizenz anfordern
:: Neue Lizenzen kaufen / Lizenzen upgraden
:: Offene und Firmenseminare

SUPPORT
:: Help+Manual-Forum
:: Help+Manual-Knowledgebase

HelpDesign • Jörg Ertelt
Ulrichstraße 1
D-73240 Wendlingen am Neckar
www.helpdesign.eu

Nach oben
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen
juliank



Anmeldungsdatum: 05.05.2015
Beiträge: 5

BeitragVerfasst am: So Dez 18, 2016 18:40    Titel: Antworten mit Zitat

Hallo Forum,
ich muss aus einer chm-Datei einen Link auf eine PDF-Datei setzen. Diese Datei ist aber nicht im chm-Verzeichnis, sondern in einem Unterordner. Ist das irgendwie möglich?
Danke für Tipps, Julian
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden
Jörg Ertelt
Moderator


Anmeldungsdatum: 22.12.2005
Beiträge: 2403
Wohnort: 73240 Wendlingen

BeitragVerfasst am: So Dez 18, 2016 22:08    Titel: Antworten mit Zitat

Guten Tag juliank,

Ist schon eine Weile her, dass ich mich in dieser Weise mit dem veralteten CHM beschäftigt habe - deshalb kann ich aus dem Stegreif keine Antwort geben.

Ich schlage vor, dass Sie das ausprobieren. Der Weg, aus einer CHM z. B. PDFs zu öffnen, ist Eingangs beschrieben. Sie müssen lediglich einen Pfad in ein Unterverzeichnis angeben - sprich zum Speicherort der CHM. Wenn diese und das PFD im selben Verzeichnis liegen, sind die Grundvoraussetzungen schon mal nicht schlecht.
_________________
Viele Grüße

Jörg Ertelt

HELP+MANUAL
:: Testlizenz anfordern
:: Neue Lizenzen kaufen / Lizenzen upgraden
:: Offene und Firmenseminare

SUPPORT
:: Help+Manual-Forum
:: Help+Manual-Knowledgebase

HelpDesign • Jörg Ertelt
Ulrichstraße 1
D-73240 Wendlingen am Neckar
www.helpdesign.eu

Nach oben
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen
Beiträge der letzten Zeit anzeigen:   
Neues Thema eröffnen   Neue Antwort erstellen    Help+Manual-Forum von HelpDesign • Jörg Ertelt Foren-Übersicht -> Microsoft HTML Help (.chm) Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehe zu:  
Sie können keine Beiträge in dieses Forum schreiben.
Sie können auf Beiträge in diesem Forum nicht antworten.
Sie können Ihre Beiträge in diesem Forum nicht bearbeiten.
Sie können Ihre Beiträge in diesem Forum nicht löschen.
Sie können an Umfragen in diesem Forum nicht teilnehmen.


Powered by phpBB © 2001, 2005 phpBB Group
Deutsche Übersetzung von phpBB.de