Help+Manual-Forum von HelpDesign • Jörg Ertelt Foren-Übersicht Help+Manual-Forum von HelpDesign • Jörg Ertelt
Erstes deutschsprachiges Help& Manual-Forum
 
 ProfilProfil   LoginLogin 
 FAQFAQ   SuchenSuchen  RegistrierenRegistrieren 
 HelpDesign { Seminare und Support | Testlizenz anfordern | Neue Lizenzen kaufen / Lizenzen upgraden }

Topic-Link zu Anker im gleichen Topic (V 7.0.0 build 3601)

 
Neues Thema eröffnen   Neue Antwort erstellen    Help+Manual-Forum von HelpDesign • Jörg Ertelt Foren-Übersicht -> BugReport
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
jotthaah



Anmeldungsdatum: 10.02.2012
Beiträge: 45

BeitragVerfasst am: Mi Jul 01, 2015 13:35    Titel: Topic-Link zu Anker im gleichen Topic (V 7.0.0 build 3601) Antworten mit Zitat

H&M Version 7.0.0:

Ich habe zum schnelleren Auffinden einen Topic-Link eingefügt, der zu einem Anker im selben Topic führt. Bei Strg + CLICK kommt die Fehlermeldung, "Topic "#[ankername]" nicht gefunden.

Plaziere ich diesen Topic-Link in einem anderen Topic, dann funktioniert es, und - höchst seltsam - wenn ich diesen Topiclink dann zurück kopiere in den uresprünglichen Topic, dann geht es.

Diese Problem hatte ich in V6.x nicht.
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden
Alexander Halser



Anmeldungsdatum: 23.12.2005
Beiträge: 228
Wohnort: Salzburg

BeitragVerfasst am: Mi Jul 01, 2015 15:49    Titel: Antworten mit Zitat

Hallo jotthaah,

wir bestätigen den Fehler. Werden wir umgehend beheben und mit dem nächsten Update ausliefern.

In Version 6 funktionierte das, in Version 7 nicht mehr. Der Grund ist, daß wir Topic-Links, welche auf einen Anker im selben Topic verweisen, in HM7 anders behandeln. Früher speicherten die Links den Ziel-Topic-ID immer explizit. Bei Links zu Ankern im selben Topic tun wir das nun nicht mehr, sondern lassen den Topic-ID leer.

Diese Änderung in HM7 macht nämlich ein paar Dinge möglich, die vorher nicht gingen: Sie können den Inhalt eines Topics samt Links und Anchors kopieren und in einem anderen Topic wieder einfügen und die Links funktionieren auch in dem neuen Topic noch. Besonders bei Snippets die mehrfach eingefügt werden, ist das praktisch. Es ist auch möglich, Topic-Vorlagen zu erstellen, die z.B. schon Text und Abschnitte mit Anchors und Links darauf enthalten und so eine Topic-Vorlage bei der Neuanlage eines Topics zu verwenden (was im Prinzip fast das selbe ist wie Copy+Paste, nur eleganter). In all diesen Fällen mußten die Anchor-Links anschließend manuell ausgetauscht werden. In HM7 funktionieren sie sofort, weil der Topic-ID nicht mehr explizit mitgespeichert wird.

Über diesen fehlenden Topic-ID stolpert aktuell die STRG+CLICK Funktion, der müssen wir das noch beibringen. Kommt umgehend.
_________________
Alexander Halser
Support, Help & Manual
www.helpandmanual.com
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen
Alexander Halser



Anmeldungsdatum: 23.12.2005
Beiträge: 228
Wohnort: Salzburg

BeitragVerfasst am: Di Jul 07, 2015 18:30    Titel: Antworten mit Zitat

Die Sache ist mit dem heutigen Update behoben:
http://www.helpandmanual.com/downloads.html?upd
_________________
Alexander Halser
Support, Help & Manual
www.helpandmanual.com
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen
jotthaah



Anmeldungsdatum: 10.02.2012
Beiträge: 45

BeitragVerfasst am: Mi Jul 08, 2015 06:59    Titel: Antworten mit Zitat

Vielen Dank, jetzt ist die Welt wieder in Ordnung Smile
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden
nkraiczi



Anmeldungsdatum: 04.11.2015
Beiträge: 10
Wohnort: DE - Rheinland-Pfalz

BeitragVerfasst am: Mi Nov 04, 2015 13:25    Titel: Antworten mit Zitat

Hallo,
seit dem Update von H&M 6 auf H&M7 (7.0.5 Build 3681) gehen bei uns die Links mit Anker (im selbsten Topic und zu anderen Topics im Projekt) nicht mehr (chm-Export). Kann dies mit o.g. Bug zusammenhängen? Hat sich diesbzgl. etwas geändert?
Danke und Gruß
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden
Beiträge der letzten Zeit anzeigen:   
Neues Thema eröffnen   Neue Antwort erstellen    Help+Manual-Forum von HelpDesign • Jörg Ertelt Foren-Übersicht -> BugReport Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehe zu:  
Sie können keine Beiträge in dieses Forum schreiben.
Sie können auf Beiträge in diesem Forum nicht antworten.
Sie können Ihre Beiträge in diesem Forum nicht bearbeiten.
Sie können Ihre Beiträge in diesem Forum nicht löschen.
Sie können an Umfragen in diesem Forum nicht teilnehmen.


Powered by phpBB © 2001, 2005 phpBB Group
Deutsche Übersetzung von phpBB.de