Help+Manual-Forum von HelpDesign • Jörg Ertelt Foren-Übersicht Help+Manual-Forum von HelpDesign • Jörg Ertelt
Erstes deutschsprachiges Help& Manual-Forum
 
 ProfilProfil   LoginLogin 
 FAQFAQ   SuchenSuchen  RegistrierenRegistrieren 
 HelpDesign { Seminare und Support | Testlizenz anfordern | Neue Lizenzen kaufen / Lizenzen upgraden }

Webhelp Skin slate_blue_horiz.hmskin

 
Neues Thema eröffnen   Neue Antwort erstellen    Help+Manual-Forum von HelpDesign • Jörg Ertelt Foren-Übersicht -> Microsoft WinHelp (.hlp)
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
mherbst



Anmeldungsdatum: 17.07.2009
Beiträge: 5

BeitragVerfasst am: Di Sep 29, 2009 07:44    Titel: Webhelp Skin slate_blue_horiz.hmskin Antworten mit Zitat

Hallo,



vielleicht kann mir hier jemand helfen. Ich habe bereits mehrere Hilfen im Webhelp-Format mit HuM 5 erstellt.



Dazu habe ich immer das Template slate_blue_horiz.hmskin benutzt. Diese habe ich nur leicht modifiziert (deutsche Ausgabetexte für die Meldungen der Volltextsuche eingetragen, etc.).



Das hat bisher auch bestens geklappt. Nun war es wieder an der Zeit ein Projekt zu überarbeiten und siehe da, bei der Generierung des neuen Help-Files taucht jetzt auf einmal in der Navigationsleiste ein viel zu großer Abstand zwischen Überschrift und erstem Kapitel auf (knapp 80 px). Das war vorher nicht so und ich kann mir das Verhalten auch nicht erklären.



Kann mir jemand sagen, wo ich in den Konfigurationseinstellungen dran drehen kann, damit dieser Abstand wieder ein normales Maß erreicht? Habe schon alle möglichen Einstellungen gesucht und versucht. Nix hilft.



Vielen Dank schon mal.

Manfred
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden
Jörg Ertelt
Moderator


Anmeldungsdatum: 22.12.2005
Beiträge: 2375
Wohnort: 73240 Wendlingen

BeitragVerfasst am: Di Sep 29, 2009 19:05    Titel: Antworten mit Zitat

Guten Tag mherbst,



==

taucht jetzt auf einmal in der Navigationsleiste

==



Meinen Sie mit Navigationsleiste das Fenster links mit Inhalt, Index, Suche?



==

ein viel zu großer Abstand zwischen Überschrift und erstem Kapitel auf

==



Überschriften gibt es in Topics - was meinen Sie mit erstem Kapitel?



Am besten ist es, wenn Sie das Projekt zippen und mir senden. Sonst stochern wir weiterhin durch die Gegend ...
_________________
Viele Grüße

Jörg Ertelt

HELP+MANUAL
:: Testlizenz anfordern
:: Neue Lizenzen kaufen / Lizenzen upgraden
:: Offene und Firmenseminare

SUPPORT
:: Help+Manual-Forum
:: Help+Manual-Knowledgebase

HelpDesign • Jörg Ertelt
Ulrichstraße 1
D-73240 Wendlingen am Neckar
www.helpdesign.eu

Nach oben
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen
mherbst



Anmeldungsdatum: 17.07.2009
Beiträge: 5

BeitragVerfasst am: Do Okt 01, 2009 06:52    Titel: Großer Abstand Antworten mit Zitat

Hallo Herr Ertelt,



Meinen Sie mit Navigationsleiste das Fenster links mit Inhalt, Index, Suche?



Ja, genau.



Überschriften gibt es in Topics - was meinen Sie mit erstem Kapitel?



Das erste Kapitel (Topic) in der Navigation, das unterhalb der Registerkarte "Inhalt" auftaucht.



Am besten ist es, wenn Sie das Projekt zippen und mir senden.



Ist unterwegs.



MfG

M. Herbst
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden
Jörg Ertelt
Moderator


Anmeldungsdatum: 22.12.2005
Beiträge: 2375
Wohnort: 73240 Wendlingen

BeitragVerfasst am: Di Okt 06, 2009 18:16    Titel: Antworten mit Zitat

Der Vollständigkeit halber für die Lösung mit einem Dank an Tim für die Umsetzung:



MS hat irgendwann ein Update für IE6 herausgebracht, das eine neuere Version von JavaScript enthält. Sehr wenige User haben dieses installiert, aber wenn es da ist, schlägt der Test für IE6 im Skin fehl. Das kann man beheben, indem man eine Zeile in den Webhelp-Templates austauscht.



Um es auch in anderen Skins zu ändern, braucht man nur in Publishing Options > Webhelp zu schauen und folgende Zeile in "Layout", "Table of Contents", "Full-Text Search" und "Keyword Index" zu finden (also jeweils einmal an 4 Stellen):



var IE6 = false /*@cc_on || @_jscript_version < 5.7 @*/;



Diese Zeile löschen und ersetzen durch:



var IE6 = /msie 6|MSIE 6/.test(navigator.userAgent);



Dann wird der Spuk vorbei sein. Funktioniert sowohl in der neuen als auch in der alten Version von IE6. Wink
_________________
Viele Grüße

Jörg Ertelt

HELP+MANUAL
:: Testlizenz anfordern
:: Neue Lizenzen kaufen / Lizenzen upgraden
:: Offene und Firmenseminare

SUPPORT
:: Help+Manual-Forum
:: Help+Manual-Knowledgebase

HelpDesign • Jörg Ertelt
Ulrichstraße 1
D-73240 Wendlingen am Neckar
www.helpdesign.eu

Nach oben
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen
Beiträge der letzten Zeit anzeigen:   
Neues Thema eröffnen   Neue Antwort erstellen    Help+Manual-Forum von HelpDesign • Jörg Ertelt Foren-Übersicht -> Microsoft WinHelp (.hlp) Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehe zu:  
Sie können keine Beiträge in dieses Forum schreiben.
Sie können auf Beiträge in diesem Forum nicht antworten.
Sie können Ihre Beiträge in diesem Forum nicht bearbeiten.
Sie können Ihre Beiträge in diesem Forum nicht löschen.
Sie können an Umfragen in diesem Forum nicht teilnehmen.


Powered by phpBB © 2001, 2005 phpBB Group
Deutsche Übersetzung von phpBB.de